Sign in to follow this  
Followers 0
Mark Tillman

Bad Amplifier Circuit in my MineLab GPX Battery-is this a simple fix?

8 posts in this topic

I have a spare battery for my MineLab GPX 4500 that I assume to have a bad amplifier circuit. The battery can be charged up and will allow me to run the detector but without amplifying the audio. As I bought the detector used, I was unaware of what the audio was supposed to sound like so I didn't discover this problem until I had a chance to try the detector using it against a different battery (another one of the neat things about attending the hands on training sessions at ICMJ's Gold Shows in Placerville). Anyway, so I have this spare battery and I'm wondering if the amplifier circuit is something that can be easily repaired since it would be nice to have a 2nd battery for those extended trips?

Share this post


Link to post
Share on other sites

I would say not really. ML does not share circuit information with the public (nor does anyone else). Unless you can see something like a lose wire that could be reconnected, I don't know what you could do without more detailed info.

I've always had good luck with ML repairing their equipment. Call the Minelab Americas office in the Chicago area I think its in Lisle, and ask what you need to do to ship it back.

Share this post


Link to post
Share on other sites
22 hours ago, Reno Chris said:

I would say not really. ML does not share circuit information with the public (nor does anyone else). Unless you can see something like a lose wire that could be reconnected, I don't know what you could do without more detailed info.

I've always had good luck with ML repairing their equipment. Call the Minelab Americas office in the Chicago area I think its in Lisle, and ask what you need to do to ship it back.

Hi Chris, I will give that a shot although it's probably not still under ML warranty. Considering the price of a new battery, I wouldn't mind so much spending a few dollars to have a backup.

 

Share this post


Link to post
Share on other sites

Just an update to my original question. I did contact Mine Lab Americas and spoke to one of the reps. She informed me that the batteries were not repairable She also was able to check the serial number on the unit to verify that it was a genuine Mine Lab as well as the manufacture date. This turned out to be something of a story in itself as there was initially some concern on ML's part that the detector might have been a counterfeit (since I had bought the detector used, this had me a bit concerned). Anyway, it was reassuring to find out that it was genuine although a bit disappointing to find that the battery was not repairable by the factory.  Earlier, I had pulled the 8 screws from the front and back of the battery in order to slide the PCB with the 8 Lithium batteries ( 4 per side) out of the case. I didn't see anything obviously wrong like a loose or broken connection so it looks like I'll be buying another battery soon or maybe instead try one of the aftermarket power packs with amplifiers such as the Gold Screamer or something similar.

Share this post


Link to post
Share on other sites

I did not know that these batteries were not repairable. It seems like an obvious problem with the amplifier as everything else seems to be fine.

Also glad to hear its not a counterfeit. 

Share this post


Link to post
Share on other sites

Yeah I guess they would rather sell a new battery than repair one. Someone else might be able to troubleshoot the circuit but it's beyond my capability so I'll be looking to pick up another one.

Share this post


Link to post
Share on other sites

A lot of the time it is just a bad op-amp circuit a .98 cent part they go out a lot a good tech could repair it without a schematic !! It could be an associated component but usually it is the op-amp in the circuit , it is doing most of the work just like a mechanical part they wear out do to friction and heat !! Electrons hitting each other during operation and inductive reactance from an inductive load, the voice coil of the speaker  and back EMF it is part of the damping factor for the amp circuit ! !!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0